NEWS: Moodle Mobile 3.5 is coming in May with a new look & feel!

On Monday 23 October, our Moodle Mobile Team Leader, Juan Leyva, posted in our forum to announce that that a new version of the Moodle Mobile app will be released at the same time as Moodle 3.5 (around May 2018).


A new look and feel Moodle Mobile app is of course very exciting news and we look forward to sharing more updates with you and ways to get involved.

In the meantime, let’s look at some more information on the what, when, why and how of the new Moodle Mobile app!

What does this new version mean and look like for our Moodle Mobile users?

The new Moodle Mobile app version will come with several UX (user experience), performance and design improvements.

The new changes we are going to implement will give the app a modern look & feel, making it easier to use by learners and teachers. In our objective effort to offer a seamless experience between devices, the new app design will be more consistent with Moodle 3.5.

To make the new app awesome (in terms of look, feel and usability) we needed new frameworks and tools. This also means that we also require the use of modern mobile devices.

Hence the new Moodle Mobile app version will only work on Android 4.4 or iOS 8 onwards devices.

However, if you have an older device you will still be able to install and use older versions of Moodle Mobile app.

What do site administrators and developers need to do now to get ready?

Administrators will need to upgrade to Moodle 3.1 onwards if they want the new app to work on their sites (older Moodle sites will still be supported via a legacy app).

Developers will need to update their remote add-ons to Ionic 3. We are working on an easier way to support Moodle plugins in the app so developers would be able to choose whether they want to update the remote add-on or support the plugin via the new “easy way”.

More questions? Check out some of our FAQs!

Is it going to be a totally new app in the stores?

No, it will be just an update of the existing app.

I’m using the app in a very old device (Android 4.3 or iOS 7) what will happen?
Your Moodle Mobile app won’t be upgraded to the new version but you will be still able to use your current Moodle Mobile app.

My site is running a Moodle version lower than 3.1, what will happen?

The new app won’t work for your site. App users will be notified about this when logging-in. They will see a notice with a link to download the legacy app for old sites.

I developed a remote add-on for the app, what should I do?
We’ll still support remote add-ons if they are upgraded to use Ionic 3 but at the same time we’ll be providing an easier way to support Moodle plugins in the app.
This new way won’t be compatible with all the existing remote add-ons although, for example, if you want to develop a question type you would still need to create a remote add-on.

What will happen with existing remote add-ons in the new app?

If they are not upgraded, they won’t work.

What’s next?
Our Moodle Mobile and UX team are working with Moodlers, members of our community and our Moodle Partners to make the new app look and feel awesome!

To get ready, we do encourage your site administrator and/or developer to upgrade your Moodle Mobile to at least version 3.1.
Instructions to upgrade can be accessed through our Moodle Docs.

To stay up to date and have the opportunity to get involved during key stages of the development, we also encourage you to follow us on Twitter at @moodlemobileapp.

Leave a Reply

Your email address will not be published. Required fields are marked *