NOUVELLES: Moodle Mobile 3.5 arrive en mai avec un nouveau look & feel!

2 novembre 2017 Par

Le lundi 23 octobre, notre chef d'équipe Moodle Mobile, Juan Leyva, a posté sur notre forum pour annoncer qu'une nouvelle version de l'application Moodle Mobile sortira en même temps que Moodle 3.5 (vers mai 2018).
moodle.org/mod/forum/discuss.php?d=360412

 

Une nouvelle apparence de l'application Moodle Mobile est bien sûr une nouvelle très excitante et nous sommes impatients de partager plus de mises à jour avec vous et des moyens de vous impliquer.

En attendant, regardons plus d'informations sur le quoi, quand, pourquoi et comment de la nouvelle application Moodle Mobile!

Que signifie et ressemble à cette nouvelle version pour nos utilisateurs Moodle Mobile?

La nouvelle version de l'application Moodle Mobile comprendra plusieurs améliorations UX (expérience utilisateur), performances et conception.

Les nouveaux changements que nous allons mettre en œuvre donneront à l'application une apparence moderne, ce qui la rendra plus facile à utiliser par les apprenants et les enseignants. Dans notre effort objectif pour offrir une expérience transparente entre les appareils, la nouvelle conception de l'application sera plus cohérente avec Moodle 3.5.

Pour rendre la nouvelle application géniale (en termes de look, feel and utilisabilité), nous avions besoin de nouveaux cadres et outils. Cela signifie également que nous exigeons également l'utilisation d'appareils mobiles modernes.

Par conséquent, la nouvelle version de l'application Moodle Mobile ne fonctionnera que sur les appareils Android 4.4 ou iOS 8.

Cependant, si vous avez un appareil plus ancien, vous pourrez toujours installer et utiliser les anciennes versions de l'application Moodle Mobile.

Que doivent faire les administrateurs de site et les développeurs maintenant pour se préparer?

Les administrateurs devront mettre à niveau vers Moodle 3.1 s'ils souhaitent que la nouvelle application fonctionne sur leurs sites (les anciens sites Moodle seront toujours pris en charge via une application héritée).

Les développeurs devront mettre à jour leurs modules complémentaires distants vers Ionic 3. Nous travaillons sur un moyen plus simple de prendre en charge Plugins Moodle dans l'application afin que les développeurs puissent choisir s'ils veulent mettre à jour le module complémentaire à distance ou prendre en charge le plugin via la nouvelle «méthode simple».

Plus de questions? Consultez certaines de nos FAQ!


Est-ce que ça va être une toute nouvelle application dans les magasins?

Non, ce ne sera qu'une mise à jour de l'application existante.

J'utilise l'application dans un très ancien appareil (Android 4.3 ou iOS 7), que se passera-t-il?
Votre application Moodle Mobile ne sera pas mise à niveau vers la nouvelle version, mais vous pourrez toujours utiliser votre application Moodle Mobile actuelle.

Mon site exécute une version Moodle inférieure à 3.1, que se passera-t-il?

La nouvelle application ne fonctionnera pas pour votre site. Les utilisateurs de l'application en seront informés lors de la connexion. Ils verront une notification avec un lien pour télécharger l'application héritée pour les anciens sites.

J'ai développé un module complémentaire à distance pour l'application, que dois-je faire?
Nous prendrons toujours en charge les modules complémentaires à distance s'ils sont mis à niveau pour utiliser Ionic 3, mais en même temps, nous fournirons un moyen plus simple de prendre en charge les plugins Moodle dans l'application.
Cette nouvelle méthode ne sera pas compatible avec tous les modules complémentaires distants existants bien que, par exemple, si vous souhaitez développer un type de question, vous devrez quand même créer un module complémentaire distant.

Que se passera-t-il avec les modules complémentaires distants existants dans la nouvelle application?

S'ils ne sont pas mis à niveau, ils ne fonctionneront pas.

Et après?
Notre équipe Moodle Mobile et UX travaille avec Moodlers, les membres de notre communauté et nos partenaires Moodle pour donner à la nouvelle application un aspect et une sensation incroyables!

Pour vous préparer, nous encourageons votre administrateur de site et / ou développeur à mettre à niveau votre Moodle Mobile vers au moins la version 3.1.
Les instructions de mise à niveau sont accessibles via nos documents Moodle.

Pour rester à jour et avoir la possibilité de vous impliquer lors des étapes clés du développement, nous vous encourageons également à nous suivre sur Twitter à @moodlemobileapp.